snook object. Dustin Diaz bundles up all his stuff under
But should namespaces be the way to go? Creating a namespace for your code helps prevent the overwriting of existing function names (which, the larger your application is, the more likely it is to happen). It's also a step in the object-oriented direction, which promotes modularity and code re-use. On the other hand, it can make your code more verbose than it needs to be. Which would you rather use,
Setting the standard?
Should the namespace be based on the domain name like it is in Java? My namespace would be
snook_ca. Should it be uppercase, like YAHOO or DED or SNOOK?
 You could do
var $ = YAHOO.util.Dom.get; to keep things simple.